on php5 ubuntu

Быстрая установка PHP 5.6 на Ubuntu 14.04 LTS

По умолчанию в Ubuntu 14.04 LTS устанавливается PHP 5.3, поддержка которой уже скоро прекратится.

Если вы не используете самописный код и древние CMS, пора обновлять PHP.

Если старого кода много, можно проверить его на совместимость с новыми версиями PHP с помощью скрипта https://github.com/wapmorgan/PhpCodeFixer, исправить ошибки и смело обновляться.

Установка PHP 5.6

Удаляем старые версии:

sudo aptitude remove php5

Устанавливаем зависимости необходимых пакетов:

sudo aptitude update
sudo apt-get install software-properties-common
sudo aptitude install python-software-properties

Добавляем самый популярный репозиторий с регулярно обновляемыми апдейтами от Ondřej Surý:

sudo add-apt-repository ppa:ondrej/php5-5.6

и ставим php (с поддержкой apache)

sudo aptitude install php5

или для использования вместе с nginx

sudo aptitude install php5-fpm

Убеждаемся, что версия изменилась:

php5 -v